Problemas con eXtplorer en su versión 2.0.0

por Ene 8, 2009Aplicaciones Web, Joomla10 Comentarios

Portada » Problemas con eXtplorer en su versión 2.0.0

Siempre he tenido lijeros problemas con esta versión de eXtplorer al instalarla como componente con Joomla, pero solo hasta ayer me di a la tarea de verificar que estaba pasando, porque solo da problemas con Joomla ya que al instalarlo como aplicación independiente funciona de maravillas.
Luego de mucho verificar (y de pocos logs porque el problema no se ve en los logs) noté que se queda únicamente cuando está comprimiendo archivos en formato .zip, cuando comprime en tar.gz, tar.bz2 o simplemente empaqueta en .tar todo funciona, luego de un lijero vistazo a la librería de funciones, noté que llama al archivo Zip.php ubicado en la carpeta libraries, pero el archivo NO estaba presente en la instalación de Joomla, sucede que «no aparece en el archivo xml de instalación», solo fue copiarlo a mano y el error se repara.
también está ausente el archivo messagebox_warning.png en la carpeta images.

10 Comentarios

  1. Alfabravo

    Moraleja: siempre revisa el log de errores de Apache o de PHP cuando tengas errores.
    Nota al pie: siempre poner a PHP y Apache a generar logs de errores y de acceso para este último!

    Responder
  2. jdcastro

    Alfabravo, el punto es que efectivamente apache estaba mostrando todos los errores, al igual php está configurado para mostrar todo, incluso advertencias…
    El punto es que no se mostraba, tengo que mirar un poco más el archivo y el porqué, pero lo que vi rápidamente es que si el archivo no estaba presente buscaba otra función 8función que si existe pero se queda colgada), creo que por eso no mostraba los logs.

    Responder
  3. Alfabravo

    Lo que pasa es que, si el error se debía a un archivo faltante, Apache debe mostrar en los errores algo como
    [Thu Jan 08 11:55:07 2009] [error] [client (ip_del_cliente)] File does not exist: /ruta/el/archivo/que/no/está.php, referer: http://url/del/script/que/lo/llama.php

    Responder
  4. jdcastro

    lo relacionado al archivo faltante lo «resolvía» la misma librería que tiene algo como:
    si file.php
    tonces: cosa…
    sino: otra cosa que no hace nada y que no sirve como debería …
    jejeee….

    Responder
  5. pablo

    Y no te da error en internet explorer?? a mi me salta fallos cada dos po tres , por ejemplo al hacer click conel boton derecho en el arbol d directorios sabes cual puede ser la causa?
    Gracias

    Responder
  6. pablo

    y no os da errores en internet explorer??

    Responder
  7. felipe

    Hola jdcastro, podrías enviarme la versión corregida por favor, gracias.

    Responder
  8. miguel

    HOOLAAA yo puedo instalar Extplorer independiente con su propia BAse de Datos?

    Responder

Enviar un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Publicidad